Ticket #122 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Downloads won't start - DTA 0.9.9.8

Reported by: zblat Owned by:
Priority: major Milestone:
Component: Downloads Version: ---
Keywords: top Cc:
Operating System: Windows

Description

I upgraded to version 0.9.9.8. but whenever I try to download something with DTA, I get an error saying "[File] could not be opened, because the associated helper application does not exist. Change the association in your preferences." This happens with whatever file I try to download.

DTA version 0.9.9.7 works just fine on my system, only the latest version has this problem. Using Firefox Z.0.0.3 on Windows XP.

Attachments

associated helper does not exist.JPG Download (13.8 KB) - added by bbwoy 9 years ago.
Pop-Up Error Message

Change History

Changed 9 years ago by MaierMan

  • version changed from 1.0 to ---
  • milestone 1.0 deleted

DiagnosticLog please?

Changed 9 years ago by zblat

Hi, the problem was fixed when I right-clicked on a link and chose "Start link with dTa on..." instead of left clicking and just choosing the "DownThemAll..." option from the download menu. Using this I was able to set the destination path, and after the successful download, left clicking now works as well.

I think the problem was this was a fresh install of dTa 0.9.9.8 on a new PC, so there was no destination path set, which caused the error. When I upgraded dTa on my laptop, it worked just fine off the bat.

About the diagnostic log, I did turn it on, but when the error was still happening nothing was being written to the logfile. It was only when I managed to download successfully that anything was written to the log.

Changed 9 years ago by thowden

Hi

I am having a similar error message. Installed dta on FF 2.0.0.3 for the first time today.

Selecting a download appears to ignore the 'Ask me where to put downloads' directive in the FF config. If I use the left-click and select either DTA or OneClick? the download starts instantly without asking for a location.

Using the right click and selecting DTA from the options gives a prompt box which has an empty field for location. Using the OneClick? option gives an error that I have not set a renaming mask or destination. Clicking ok gives the same prompt box as for the DTA option so there is an inconsistency there as well. The renaming mask appears to be set ok, and the destination directory is not set because I don't know where to set it nor that I needed to. I think this error should come up if the prompt box has been displayed and the data is incorrect rather than before.

In any case, if I let the download run then at the end of the download I get the helper app error and if I click ok the download is shown as 'failed' and the file cannot be found on the drive. I then tried again and this time waited to check the temporary file location before clicking ok. The downloaded file was there so I copied it. Once I clicked on ok the file was deleted. I don't know what helper app is being referred to, but I do not want the file to be opened in any case.

Changed 9 years ago by bbwoy

Pop-Up Error Message

Changed 9 years ago by bbwoy

Getting same on FF 2.0.0.3 running on Win XP SP2. Included screenshot of error message

DTA 0.9.9.8.

Great extension btw! :)

Changed 9 years ago by MaierMan

  • priority changed from critical to major
  • status changed from new to closed
  • resolution set to fixed

Sorry, my fault. Got an id wrong.
Fixed: [287], [288]

In the meantime this work-around seems to fix it (because of this I missed this in the first place :p):

Workaround: Start a download from the right click context menu (not OneClick).
Once dTa remembers a download directory this error should not occur anymore.

Changed 9 years ago by MaierMan

  • milestone set to 0.9.9.9

Changed 9 years ago by MaierMan

  • keywords top added

Changed 9 years ago by MegaEduX

  • status changed from closed to reopened
  • resolution fixed deleted

I'm getting the same error... But the download starts in FF download manager and it fails at end :(

Changed 9 years ago by MaierMan

  • status changed from reopened to closed
  • resolution set to fixed

Read the comments please. This bug is dead. Wait for next version (which will be released soon) or try the workaround.

Changed 9 years ago by anonymous

  • milestone 0.9.9.9 deleted

Milestone 0.9.9.9 deleted

Note: See TracTickets for help on using tickets.